LFA SuperLeague 2.0 Requirements

lfasl1

 

You’ll need a PC that supports MS-DOS or an MS-DOS emulator to play this game.

As newer PC Operating Systems (eg Windows 8, Windows 7, Windows Vista, Windows XP) do not typically support MS-DOS, if you have a newer PC, you should download DOSBox from the Installation page.

What’s DOSBox? DOSBox is free open-source software that can emulate MS-DOS on your new PC and sort you out.